image
Inicio » Foros » Instalación PHP, Apache, MySQL, PHPNuke

Foro sobre Instalación PHP, Apache, MySQL, PHPNuke

acceso denegado a PhpMyadmin.error #1045

Volver al foro | Responder | Añadir nuevo tema


De: Oscar
Fecha: 29/06/2006
Mensaje:

Buenas.

Tengo cierto problemilla que me trae de cabeza.

No puedo acceder al panel de Phpmyadmin por que mesale esto:

MySQL ha dicho:

#1045 - Access denied for user 'root'@'localhost' (using password: YES)

Y es que se me ocurrio borrar el usuario defalut del Mysql.

Que puedo hacer??

Os agradeceria ayuda , toy mu atascado. Gracias.




Quizás le interese
De: shaka
Util para: 158 personas

Fecha: 30/06/2006
Mensaje:

BUenas tienes que configurar el phpmyadmisn y darle ub password al root, me paso lo mismo



De: cala
Util para: 16 personas

Fecha: 03/07/2006
Mensaje:

a mi me paso lo mismo tenes que configurar el config.ini del administrador y si no tenes solucion y estas trabajando con el paquete appserver. reinstalalo salvando las carpetas donde tienes la base y los formularios. yo las salve pero inmediatamente de reinstalarlo no me hizo falta recuperarlas, lo hizo solo windows y todavia no se como pero solucione el problem. saludos y suerte



De: zafanor
Util para: 9 personas

Fecha: 02/02/2008
Mensaje:

yo lo hice bastante simple y me funcionó a la prefección. Hice lo siguiente.
1º.- Con el RevoUninstallers eliminé por completo todo los registros de WAMP 2.0.
2º.- Y el segundo paso fue instalar todo WAMP 2.0 de nuevo.





De: MAICOL
Util para: 24 personas

Fecha: 08/02/2008
Mensaje:

A mi me ocurrio lo mismo, me puse a modificar privilegios asigne un password al ROOT y se me presentaba el mismo inconveniente: PhpMyadmin.error #1045. La solucion a eso fue editar el archivo config.inc.php modifique la siguiente linea ingresando un password: $cfg['Servers'][$i]['password'] = ''; Luego vas a: $cfg['ShowChgPassword'] = FALSE; y tambie modificas el valor (TRUE O FALSE). y listo ya tienes acceso a phpmyadmin nuevamente.



De: luis_bogota
Util para: 1 personas

Fecha: 08/02/2008
Mensaje:

OK me funciono, hive lo siguiente: 1. abri el archivo: config.inc.php. 2. modifique la siguiente linea: $cfg['Servers'][$i]['password']= 'myclave'; 3.modifique tambien la siguiente: $cfg['ShowChgPassword'] = true; (recuerden que solo se puede FALSE o TRUE). listo ya pude ingresar al administrador. Gracias Maicol por tu colaboracion.ok.



De: Fueru
Util para: 1 personas

Fecha: 28/02/2008
Mensaje:

Gracias MAICOL,

me funcionó con lo que dijiste ;)



De: Alejandro
Util para: 8 personas

Fecha: 20/06/2008
Mensaje:

por si les sirve, empleando la receta de arriba, tambien funciono y sali del error tonto de phpmyadmin: $i++; $cfg['Servers'][$i]['host'] = 'localhost'; $cfg['Servers'][$i]['extension'] = 'mysql'; $cfg['Servers'][$i]['connect_type'] = 'tcp'; $cfg['Servers'][$i]['compress'] = false; $cfg['Servers'][$i]['auth_type'] = 'config'; $cfg['Servers'][$i]['user'] = 'root'; $cfg['Servers'][$i]['password'] = 'etcetc'; $cfg['ShowChgPassword'] = true; $cfg['Servers'][$i]['only_db'];



De: merilaim
Util para: 2 personas

Fecha: 14/03/2010
Mensaje:

hola he logrado solucionar este error.
Hoy instale mysql 5.1.44 y all momento de configurar las opciones de seguridad (modify security settings)llene mal los campos current root password le introduje una palabra lo que yo no sabia es que ese campo debe ir en blanco.
y ya en los siguientes dos puse mi contraseña, ya cuando se estaba instalando la configuración me marco el error 1045 donde me decía que no tenia permisos.
lo que hice de nuevo fue des instalar mysql y borrar la carpeta con el mismo nombre en c: después lo volví a instalar y al ejecutar mysql instance config wizar de lugar de elegir reconfigure instance elegí remove instance y le di ejecutar.
después me aparecio un mensaje donde me decia que la instancia había sido removida.
Después reinicie mi computadora y volvi a ejecutar mysql instance config wizar pero ahora si elegí reconfigure instance y al llegar a las opciones de seguridad (modify security settings) solo llene los campos new root password y confirm con mi contraseña. Aclaro no llenen el campo que dice current root pasword.
despues de esto la instalacion fue exitosa y ahora ya puedo acceder.

Espero y le sirva ami me funciono.



De: Zchrs
Util para: 3 personas

Fecha: 25/11/2013
Mensaje:

en mi caso tengo el mismo problema pero ya en el servidor web, ¿tendrá solución el estarlo trabajando directamente en un servidor web?

este es el mensaje de error más detallado.
Warning: mysql_connect(): Access denied for user 'u213574223_tavo'@'localhost' (using password: YES) in /home/u213574223/public_html/registro.php on line 19 Warning: mysql_select_db(): Access denied for user 'root'@'localhost' (using password: NO) in /home/u213574223/public_html/registro.php on line 20 Warning: mysql_select_db(): A link to the server could not be established in /home/u213574223/public_html/registro.php on line 20 Warning: mysql_query(): Access denied for user 'root'@'localhost' (using password: NO) in /home/u213574223/public_html/registro.php on line 21 Warning: mysql_query(): A link to the server could not be established in /home/u213574223/public_html/registro.php on line 21 Te has registrado correctamente,en breve recibir�s un mensaje de confirmaci�n de cuenta.



Volver al foro | Responder | Añadir nuevo tema

Quizás le interese:

WebEstilo.com no se hace responsable de las opiniones que los usuarios puedan verter en cualquiera de los foros existentes.

Si te solucionó el problema pulsa en G+1


Gracias!






Comparte



Última modificación:05 de Agosto de 2012. Spain - España.
© 1998-2004 por . Todos los derechos reservados.